Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

Thread: The OpenWrt Thread

  1. #16
    Elite Master Razor's Avatar
    Join Date
    21.07.08
    Location
    Bucharest, Romania
    Posts
    1,448
    Activity Longevity
    9/20 18/20
    Today Posts
    1/5 sssss1448
    So, I have flashed the image above, and it did work correctly until I figured out I forgotten to add the ip package and qos-scripts.
    I built the image again, and the compiler generated the new image without errors. Of course I flashed it correctly, and of course it failed. The first flash i ever did to this router than managed to have the error: no space available. I guess you flashed a different router, or other firmware version. I lost everything and had to re-created it from my backups which had about 90% of the router config.
    It took 2 hours to re-flash the router from failsafe, with netcat which did not work from windows due to firewall issues. And another 6 hours to repair all configs.

    I can't get ipv6 to work, on lan or wan. I can't remeber how I setted up 4 years ago.
    I have the following setup, which is not working:
    /etc/config/network
    config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ipv6 '1'

    config interface 'wan'
    option ifname 'eth1'
    option proto 'pppoe'
    option username ''
    option password ''
    option ipv6 '1'
    /etc/config/dhcp
    config dhcp lan
    option interface lan
    option start 100
    option limit 150
    option leasetime 12h
    option dhcpv6 'server'
    option ra 'server'
    option ra_management '1'
    option ra_default '1'
    option ndp 'hybrid'

    config dhcp wan
    option interface wan
    option ignore 1

    /etc/sysctl.conf
    net.ipv6.conf.all.forwarding=1
    All ping6 operations result in unknown route to host or timeout.
    Whenever you find yourself on the side of the majority, it is time to pause and reflect. - Mark Twain.
    ... and since I can remember, I've always been different that others, and I've never been on the majority side.
    I am the one and only Master Razor... lost in a world of billions of people.
    Reply With QuoteReply With Quote
    Thanks

  2. #17
    Moderator anon's Avatar
    Join Date
    01.02.08
    Posts
    33,621
    Activity Longevity
    12/20 19/20
    Today Posts
    5/5 ssss33621
    Quote Originally Posted by Master Razor View Post
    So, I have flashed the image above, and it did work correctly until I figured out I forgotten to add the ip package and qos-scripts.
    I built the image again, and the compiler generated the new image without errors. Of course I flashed it correctly, and of course it failed. The first flash i ever did to this router than managed to have the error: no space available. I guess you flashed a different router, or other firmware version. I lost everything and had to re-created it from my backups which had about 90% of the router config.
    It took 2 hours to re-flash the router from failsafe, with netcat which did not work from windows due to firewall issues. And another 6 hours to repair all configs.
    With a custom bootloader, you'd have been able to reflash without netcat or failsafe mode, and even download a full copy of the firmware as stored on the flash chip to then mount and read the YAFFS2 partition on your computer

    Be very careful if you install one, because a mistake will brick your router forever, but there are detailed tutorials and after that it's smooth sailing.

    I can't get ipv6 to work, on lan or wan. I can't remeber how I setted up 4 years ago.
    I have the following setup, which is not working:
    I've never used IPv6 on PPPoE (no ADSL providers here support it), but I'm sure we can figure this out.

    First things first, are you getting an IPv6 address at all on the wan interface? If you do, try using ping6 from the router (you may need to add the parameter -I wan or -I <your IPv6 here> to make sure it pings from the right interface) and see if you get a response. If you do, everything's fine on the WAN side, you now need to setup prefix delegation or router advertisements (depending on what your provider supports) to get your LAN online.

    If you don't, you may need to create a virtual interface that is also bound to eth1 but uses dhcpv6 as the protocol. Do that and see if it gets an address then.
    "I've seen the future and I leave it all behind."
    Reply With QuoteReply With Quote
    Thanks

  3. #18
    Elite Master Razor's Avatar
    Join Date
    21.07.08
    Location
    Bucharest, Romania
    Posts
    1,448
    Activity Longevity
    9/20 18/20
    Today Posts
    1/5 sssss1448
    For the IPv6 issue:
    I have ipv6 connectivity on the router but it works only for external hosts. Cannot ping any internal ipv6 host.
    I can ping any external address, both IP and DNS but ping doesn't work for any internal address, router, hosts, nothing.
    Here is my config:

    /etc/config/network
    https://pastebin.com/riwYmdWA

    /etc/config/dhcp
    https://pastebin.com/j4nsH0ha

    /etc/config/dhcp6c
    https://pastebin.com/SgYHUNc3

    /etc/config/radvd
    https://pastebin.com/DvW1D4sH

    /etc/sysctl.conf
    https://pastebin.com/D38C5c9x


    My router did not receive IPv6 from provider until I set this setting to on:
    config 'dhcp6c' 'basic'
    # Send options (1 = send; 0 = do not send)
    option 'pd' '1' # Prefix Delegation
    option 'na' '1' # Non-Temporary Address
    option 'rapid_commit' '1' # Rapid Commit
    Please assume I know nothing of IPv6.
    Whenever you find yourself on the side of the majority, it is time to pause and reflect. - Mark Twain.
    ... and since I can remember, I've always been different that others, and I've never been on the majority side.
    I am the one and only Master Razor... lost in a world of billions of people.
    Reply With QuoteReply With Quote
    Thanks

  4. #19
    Elite Master Razor's Avatar
    Join Date
    21.07.08
    Location
    Bucharest, Romania
    Posts
    1,448
    Activity Longevity
    9/20 18/20
    Today Posts
    1/5 sssss1448
    I think I also need wide-dhcpv6-server to be installed. And since I have no more space left on the route, I will have to give up the bash package as it is the largest one.
    Whenever you find yourself on the side of the majority, it is time to pause and reflect. - Mark Twain.
    ... and since I can remember, I've always been different that others, and I've never been on the majority side.
    I am the one and only Master Razor... lost in a world of billions of people.
    Reply With QuoteReply With Quote
    Thanks

  5. #20
    Moderator anon's Avatar
    Join Date
    01.02.08
    Posts
    33,621
    Activity Longevity
    12/20 19/20
    Today Posts
    5/5 ssss33621
    Sorry for the delay. Did you try this?

    Quote Originally Posted by anon View Post
    create a virtual interface that is also bound to eth1 but uses dhcpv6 as the protocol
    I'm guessing your provider offers connectivity through DHCPv6 prefix delegation. In that case you don't need radvd for your LAN, but you'll need to specify an ip6assign length for the lan interface.

    If you really know nothing about IPv6, this is definitely worth a read: https://wiki.openwrt.org/doc/uci/network6

    dnsmasq-dhcpv6 already provides you with a local DHCPv6 server, so I don't think you need wide-dhcpv6-server. Come to think of it, I don't think you need wide-dhcpv6-client either, since odhcp6c provides the same functionality, but I keep forgetting you're on 12.09 and things could be different. Which takes me to the following point...

    Consider installing the x86 version of OpenWrt in a virtual machine, so that you can experiment with packages and configurations in a safe and fast way. A $2 USB Ethernet adapter would be nice but optional (you can disable all protocols and clients on Windows, then bridge your physical adapter to the VM).
    "I've seen the future and I leave it all behind."
    Reply With QuoteReply With Quote
    Thanks

  6. #21
    Elite Master Razor's Avatar
    Join Date
    21.07.08
    Location
    Bucharest, Romania
    Posts
    1,448
    Activity Longevity
    9/20 18/20
    Today Posts
    1/5 sssss1448
    Could you share a working tinyproxy config along with the firewall config for it?
    I enabled the proxy in tinyproxy and left everything else to default.
    However, when I use the proxy in a web browser, on some sites I get "The proxy server is refusing connections" .
    Last edited by Master Razor; 01.10.17 at 00:19.
    Whenever you find yourself on the side of the majority, it is time to pause and reflect. - Mark Twain.
    ... and since I can remember, I've always been different that others, and I've never been on the majority side.
    I am the one and only Master Razor... lost in a world of billions of people.
    Reply With QuoteReply With Quote
    Thanks

  7. #22
    Moderator anon's Avatar
    Join Date
    01.02.08
    Posts
    33,621
    Activity Longevity
    12/20 19/20
    Today Posts
    5/5 ssss33621
    Quote Originally Posted by Master Razor View Post
    when I use the proxy in a web browser, on some sites I get "The proxy server is refusing connections" .
    This is what logs are there for! When something goes wrong, check /var/log/tinyproxy.log to see what caused it and why.
    "I've seen the future and I leave it all behind."
    Reply With QuoteReply With Quote
    Thanks

  8. #23
    Elite Master Razor's Avatar
    Join Date
    21.07.08
    Location
    Bucharest, Romania
    Posts
    1,448
    Activity Longevity
    9/20 18/20
    Today Posts
    1/5 sssss1448
    This is what logs are there for! When something goes wrong, check /var/log/tinyproxy.log to see what caused it and why.
    The logs aren't working.
    Had to do this to make them output something, that isn't even remotely relevant to the subject matter.
    touch /var/log/tinyproxy.log
    chown nobody.nogroup /var/log/tinyproxy.log
    /etc/init.d/tinyproxy restart
    Nothing actually works on Openwrt and the documentation, all of it, is shit. Everything is trial and error because the real implementations from other distros do not match the Openwrt one.

    As a side note, you really screwed me over with space advice you gave. 1 month almost passed and still no IPv6 or anything useful. The damage to my free time is enormous.
    I'll have no more talk about. Consider it closed.
    Whenever you find yourself on the side of the majority, it is time to pause and reflect. - Mark Twain.
    ... and since I can remember, I've always been different that others, and I've never been on the majority side.
    I am the one and only Master Razor... lost in a world of billions of people.
    Reply With QuoteReply With Quote
    Thanks

  9. #24
    Moderator anon's Avatar
    Join Date
    01.02.08
    Posts
    33,621
    Activity Longevity
    12/20 19/20
    Today Posts
    5/5 ssss33621
    Quote Originally Posted by Master Razor View Post
    As a side note, you really screwed me over with space advice you gave. 1 month almost passed and still no IPv6 or anything useful. The damage to my free time is enormous.
    I'll have no more talk about. Consider it closed.
    Razor, being hostile towards me isn't going to solve anything. Why don't you tell us what else you've tried since last month and what's left to fix? You didn't answer several of my questions about your IPv6 setup.

    As for the tinyproxy logs, you're using (or are forced to use) a beta of an old release, so keep that in mind if something doesn't work as expected.

    https://dev.openwrt.org/ticket/9015

    This bug was fixed on 2014 and tinyproxy works out of the box on LEDE 17.07.1. Anyway, make sure to put those commands on your /etc/rc.local because the contents of /var are lost after a reboot.
    "I've seen the future and I leave it all behind."
    Reply With QuoteReply With Quote
    Thanks

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126